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Proprietary + Confidential

No-Code / Low-Code 全球趨勢

根據 Gartner, Inc. 的最新預測，全球低代碼開發技術市場預計到 2023 年將達到 269 億美元，

相比2022 年增長 19.6%。

越來越多企業轉向低代碼開發技術，以應對快速變化的需求並建立靈活的商業規劃，預估在2026 年，此

需求將成為推動低代碼技術被大量應用的主因。

Gartner 預測在 2026 年傳統 IT 部門以外的開發者將佔 No-Code / Low-Code 工具使用者的 80%。 

資料來源：Gartner 
https://www.gartner.com/en/newsroom/press-releases/2022-12-13-gartner-forecasts-worldwide-low-code-development-technologies-market-to-grow-20-percent-in-2023
https://www.gartner.com/en/newsroom/press-releases/2021-02-15-gartner-forecasts-worldwide-low-code-development-technologies-market-to-grow-23-percent-in-2021

https://www.gartner.com/en/newsroom/press-releases/2022-12-13-gartner-forecasts-worldwide-low-code-development-technologies-market-to-grow-20-percent-in-2023
https://www.gartner.com/en/newsroom/press-releases/2021-02-15-gartner-forecasts-worldwide-low-code-development-technologies-market-to-grow-23-percent-in-2021


Agenda
✔ AppSheet 回顧上一堂

✔ Slice

✔ Behavior

✔ 自動化觸發

✔ 權限控管

✔ OCR辨識

✔ 版本及佈署



上一堂課程｜回顧



操作

建立資料模型

七大步驟

介面邏輯

簡單App製作

理解

需求探索

實務應用場景

AppSheet用途 / 特色

設計構思
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本次課程｜涵蓋範圍



深入設定

Do this

Group by / Sort by / 
Group aggregate / Action icon

Slice / 運算式

自動觸發通知

基本操作

Behavior

UX

Data

Automation
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AppSheet 簡介



Proprietary + Confidential

AppSheet
使用 No-Code / Low-Code 平台，協助獲取更多的時間與人力

AppSheet

使用 APP 和自動化簡化工作，讓員工更

智慧、更高效地工作。

通過任何人都可以學習的 No-Code 平
台，縮短實現價值的時間

構建與您已經使用的 APP 與資料，定義

解決方案



Proprietary + Confidential

程式語言

Gartner Report: The Future of Apps Must Include Citizen Development

傳統開發 與 無代碼(低代碼) 應用程序開發

技巧

無代碼或低代碼工具

技巧
傳統 Citizen Developer

https://www.gartner.com/document/3970067


這些應用程式在哪裡？

除了大型系統之外，是否有另外
的工具或應用程式？如：流程管
理工具、簽核工具、回報工具

??



他們需要更多小工具

來完成繁雜的日常作業或業務

的前線員工表示，

更多新技術的導入

能幫助他們把工作做得更好

70%

Frontline Workers

● 沒辦法坐在辦公室工作

● 主要使用行動裝置

● 70-80% 的員工還是使用紙本表單（可能還有資安疑慮）

● 紙本的模式導致大量的文書工作和簽核，效率低下（複雜的任務步驟，尤其是對於新員工）



在最短時間內完成開發
Use the power of no-code to move faster from idea to solution

有想法立即付諸行動

簡化工作

縮短時間

客製化需求

Idea Project Spec Dev Team Code Solution



智慧的無程式碼平台
A smarter way to work, built by you

⌦ 無需撰寫程式碼，任何團隊成員都可以建立 App

提供絕佳用戶體驗與客製化功能

作為第一線的平台，蒐集表單、QRcode、定位、簽名等資料

基於角色的安全性、身份驗證來管理員工帳號



快速部署
One-click deploy to multiple platforms

透過 AppSheet 建立的動態應用程式，可

在各種行動裝置或瀏覽器上使用，支援多

平台各種大小的裝置



建立 及 擴充應用程式
Transform and optimize your business operations with no-code business apps

Capture Images

Log LocationsScan Barcodes, QR 
Codes & NFC Tags

Deliver 
Notifications

Work OfflineInstall Across 
Devices

Accept Signatures Generate Reports Build DashboardsApply Logic

Send Emails Integrate Platforms



App CreatorsApplicationsApp Users Data

Apigee API 
Platform

前線員工/公司同仁 BU單位/老闆 資訊人員



Incident Report

Manager 
Approvals

Event 
Management

Field Delivery

Expenses

Health 
Assessment

Facility 
Inspections Team Alerts

Leave 
Requests

Curbside 
PickupKanban Board

TimesheetQuote 
Generator

Repair 
Ticketing Virtual Training

Inventory 
Management Account Health

Resource 
Portal

AppSheet 延伸至 Google Workspace 的其他可能 



將 AppSheet 與 Google 
Workspace 緊密的連結

AppSheet

Drive
Access shared folders 
for app data and 
content 

Sheets
Create, read, update, 
and delete Sheets data 
directly from app 

Forms
Expand Forms 
functionality with data 
intake features

Docs
Create custom 
templates for 
notifications and files 

Calendar
Integrate and update 
events from existing 
calendars 

Meet
Launch Meet directly 
from AppSheet



可使用 AppSheet 的情境

圖形化的報表展現 (資料收集、視覺呈現)

彌補公司系統沒有涵蓋到的工作需求 (Frontline Workers 前線員工小工具)

開發者擁有基本概念 (Basic DB Concepts)

想要客製化公司系統 (結合 Google Workspace 的服務)



不建議使用 AppSheet 的情境

需要撰寫大量的程式碼 (AppSheet 不允許使用個人程式碼)

具有大量邏輯的應用程式 (應用程式有深入分析的場景)

複雜的 Use case 設計 (盡量以簡單的功能為主)

針對行動裝置設計的服務 (AppSheet 不是 Native 的應用程式)



AppSheet特色

快速應用開發

1天 至 1週

提升行動力

現場、前線、外勤

整合多個數據源

Dropbox、SQL、Sheet…

可在不同裝置使用，無論是在

會議中、活動現場還是外勤工

作中，皆可方便地使用

AppSheet 應用程式執行任務，

並即時收集和更新數據。

可連接和整合多個數據來源，

例如資料庫、試算表、線上服務

等。

輕鬆地將不同來源的數據整合

到應用程式中，實現全面的數

據管理和分析，並更好地管理

公司及客戶。

低代碼開發平台，非技術人員

也能快速創建專屬的應用程式

，無需編寫繁瑣的程式碼。

滿足不同行銷需求，包括活動

報名、產品展示、客戶調查等，

加快行銷活動的執行速度。
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Google Workspace with Cloud Identity
Enabling BeyondCorp for organizations everywhere

Google Workspace 提供各種規模的團隊使用、溝

通、創作，是一個適用於所有工作方式的生產力工具

與協作工具，能以獨立產品的方式與其他 Google 服
務搭配使用提供身分認證，例如 GCP、AppSheet

其核心的身份管理服務就跟 Microsoft AD 一樣，不

管是使用者(User)、群組(Group)、電腦(Device)、組
織單元(OU)...等，都可以讓管理員透過單一位置 (管
理控制台) ，做集中式目錄管理與權限設計

Google 
Cloud

Android for 
Work

Chrome 
for Work

身份管理服務

Apps

People

Devices



安全的登入限制與 Google 生態系

使用者

設備

IP
LocationIP

Session Age

Time

Context-aware policies
(Google Workspace console) (GCP console)

Google 
Workspace

✔ Cloud IAP
✔ Cloud IAM
✔ Cloud Identity
✔ VPC SC

Apps and data

Web apps

VMs

SaaS apps

Infrastructure

APIs

Network



AppSheet 開發



[ 02.a ]

AppSheet Demonstration
Journey & Best Practices

評估與驗證
• 評估業務端的可行性與 AppSheet 技術上可行
性

• 驗證收集的使用情境
• 定義關鍵情境，藉此評估設計上是否可行。

Discovery: 找尋應用，列出需求

[ 01 ]

PoC / Production
• 定義需求情境與範疇
• 定義成功標準

[ 04 ]

• 可使用現有的模板快速製作 Demo 畫
面

•  可考慮 Google Workspace 相關整合
與進階的資料應用

建立與訂製要 Demo 
的範疇

[ 02.b ]

收集關鍵的
使用情境

• 實際演示 AppSheet 如何做出關鍵使用情境
• 介紹該平台給平民開發人員 
• 說明安全性與維護方式
• 持續往 Production 推進

[ 03 ]

定義關鍵使用
情境

建立關鍵使用
情境 Demo 

若同意則往下階
段前進

反覆檢視

實際演示 Demo 作品

Start 
Here

BEST 
PRACTICE

Opportunity 
Qualification

• 需求單位與開發單位共同構建關鍵的使用情
境。



需求探討

How
方案

Why
問題

When
場景

Who
人

When
發生時間

What
執行

Deep Why
底層問題



文檔資料 解決問題場景使用者

● 辦公室
● 門店
● 現場
● 工廠
● 倉庫
● 業務財務
● 物流配送
● 客戶互動
● 前台 / 後台
● 上游 / 中游 / 下游

● 新進人員
● 內勤人員
● 外勤人員
● 專業人員
● 對外服務
● 管理者
● 查驗人員
● 配送人員
● 供應商 / 承包商

● 定期檢查
● 問卷回饋
● 規劃討論
● 項目追蹤
● 掃描辨識
● 分類記錄
● 服務
● 簽署
● 申請批淮
● 活動管理
● 時間地點記錄

● 品質穩定
● 資源分配
● 快速調度
● 時間效率
● 準確率提高
● 信賴關係
● 有效管理
● 提醒通知
● 創新創造

需求探討



現場使用 連結互動辦公室品控維護

● 申請單與批淮

● 專案管理和協作

● 預算規劃和追蹤

● CRM 附加功能

● 打卡請假

● 安全檢查/品質保證

● 設施和維護

● 設備檢查

● 時間排程

● 庫存追蹤

● 司機調度

● 物流派送

● 確認簽名

● 現場服務

● 現場資源管理

● 資產管理

● 廠商管理

● 條碼掃描

● 提案和報價產出

● 專案排程管理

● 客戶管理

● 通知提醒

● 教育訓練

● FAQ

場景需求



開發 AppSheet 的流程

1. 串接資料來源

2. 客製化需求與表單管理

3. APP 佈署



AppSheet APP 給予權限



AppSheet APP 應用層級權限設計

類似於資料庫關聯設計，賦予不同角色於該 
APP 中能有不同的操作行為。

AppSheet APP 權限僅限制登入者是否可

以使用該 APP 以及是否可編輯修改，但 
APP 應用內的權限及功能，需要由開發端

自行設計及開發。



各場景類型的官方 App Sheet 範本

https://docs.google.com/file/d/1xxdzUG3oJbVeZ7pMyjUfotfMmmejmGl4/preview


第一次入門可以怎麼做 ? - １
- 複製官方 App Sheet 範本

https://docs.google.com/file/d/1rGzl8lwki1k6EvIIsXOrSFzsxQinig3H/preview


第一次入門可以怎麼做 ? - ２
- 他人分享 App Sheet 給自己

https://docs.google.com/file/d/1lmC8yG11td19BRgFq_7vgFikGv7l0GqW/preview


Simple Demo



7 個步驟建立、開發及
部署應用程式

1 2 3 4 5 6 7



1. 準備資料

- 準備Column Header

- 準備 Data Type

- 準備Data



2. 連結資料來源至AppSheet：方法1

- 方法1：AppSheet 中建

立連結

- 方法2：Google Sheet

中建立 AppSheet

https://docs.google.com/file/d/1dFEtbD96xj1M1BOUetbV1LXWD0iJE6se/preview


可連接多種資料來源

資料庫 各式第三方服務平台資料表

Google Sheets and Drive

Excel on Office 365

Excel on Dropbox

Excel on OneDrive

Excel on Box

BigQuery

SQL Server

mySQL

PostgreSQL

AWS DynamoDB

Apigee

Smartsheet

Salesforce

Airtable

OData



[Data] 資料來源 - Google Sheet



2. 連結資料來源至AppSheet：方法2

- 方法1：AppSheet中建

立連結

- 方法2：Google Sheet

中建立AppSheet

https://docs.google.com/file/d/1G_06U9sH1lYdzbpr-_ElB43eSeBmdvxN/preview


AppSheet Layout

★ Navigation bar
○ Data
○ UX
○ Action
○ Automation
○ Other

★ Edit pane
○ 設計畫面

○ 操作畫面

★ Preview 

Navigation bar Edit pane Preview



3. 定義資料處理方式

- Tables：資料來源

- Columns：
Name / TYPE / KEY? / LABEL? / 
FORMULA / SHOW? / 
EDITABLE? / REQUIRE? / 
INITIAL VALUE / DISPLAY 
NAME / DESCRIPTION / 
SEARCH? / SCAN? / NFC? / 
PII?

- Slices
- User Settings
- Options

https://docs.google.com/file/d/1rOxDjtvU0RusfohdV2MKsfx39v2ii3FY/preview


登入檢查帳號：給予資料權限



[Data] 什麼是 Data ?

- 整個 APP 的資料來源，一個 APP 可以連結多個資料來源

- 定義 APP 所需要用到的資料

- 可於此處理資料顯示的邏輯

- 可於此做資料權限管理

- 可於此決定資料可操作的行為 (CRUD)



[Data] 資料管理介面

- 所有資料來源皆從

此介面進行設定

- 定義資料欄位、型

態以及顯示設定 
( 必填? 是否顯示? )



[Data] 資料管理介面

1. View Columns
2. View Source
3. View Data
4. Add Virtual Column
5. Security filter



[Data] 很重要的功能 - Slice

1. 切片的目的

2. 切片的效果

3. 狀態呈現很有用



4. 設計畫面

- UI 外觀設計

- 提供主題色、Logo、啟
動畫面等相關設計，

- Format Rules 針對不同

條件的資料給予不同樣

式。

https://docs.google.com/file/d/1Y7qit4oyUnMO2lMBc3iUhxH88i8QYn3o/preview


4. 設計畫面

- Views：要呈現哪些頁

面

- Brand：提供主題色、

Logo、啟動畫面等相關

設計，

- Format Rules：針對不

同條件的資料給予不同

樣式(ex. High light)



[UI/UX] 什麼是 UI/UX?

- 操控整個 APP 的畫面 (包含主畫面、編輯畫面、細節畫面)

- 可決定每個畫面想要呈現的樣式

- 可決定 APP 畫面的整體 Style

- 可客製特殊情況下的畫面顯示



[UI/UX] AppSheet Views Types



[UI/UX] Format Rules



不同的 Role 會 Show 不同的畫面



5. 加入操作方式

- 執行特定的操作。

- 協助 AppSheet 執行各

種不同的任務。也可以

執行一系列動作。

- 包含資料的改動、App畫
面的轉換等相關動作皆

可被設定執行。



[ACTION] 什麼是 Actions

- 在有限範圍內，提供使用者於畫面中有其他操作形式。

(Ex. 一鍵設定管理員/成員)

- 可一次群組化多項 Actions

- 通常搭配使用者畫面操作或機器人執行

- 提供新增、刪除、修改、查詢外的選擇

- 提供 Offline 使用 (有容量上限)



[ACTION] 行為種類

- 執行特定的操作。

- 協助 AppSheet 執行各種

不同的任務。也可以執行

一系列動作。

- 包含資料的改動、App畫
面的轉換等相關動作皆可

被設定執行。



[ACTION] 執行預先定義好的行為

- 執行特定的操作。

- 協助 AppSheet 執行各種

不同的任務。也可以執行

一系列動作。

- 包含資料的改動、App畫
面的轉換等相關動作皆可

被設定執行。



[ACTION] 如何調用 Action

- 進入 UI/UX 畫面

- 點選 Use Action
- 選擇想要呈現的 Action



6. 設定自動化機器人

- 透過機器人，能夠自動

化做到寄信、通知、簡

訊或呼叫外部 API
- 可以設定觸發條件，再

執行 Process



[Automation] 什麼是 Automation?

- 希望自動化之事項

- 在有限的觸發條件及有限的處理行為下進行

- 可透過此機制寄信、發送推播、寄簡訊

- 可使用 Webhook

- 可設定排程執行



6. 設定自動化機器人

- 透過機器人能夠自動化

做到寄信、通知、簡訊

或呼叫外部 API
- 可以設定觸發條件，在

執行 Process



6. 安全性控管

- 身份驗證

- 網域驗證

- 資料安全



7. 儲存與佈署

- 佈署檢查

- 一鍵執行儲存與佈署
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03
AppSheet 動手做



Data

UX

Behavior

Automation



Step 1. 建立官方範本
進入 Appsheet 頁面，點選「Create」->「APP」->「Start with a template」

Step 2. 下載手機 AppSheet APP
至 Google Play 或 Apple Store，搜尋 AppSheet 下載並安裝，並登入。

Step 3. 將已有 AppSheet APP製作捷徑到桌面
1. 點選 APP 左上角☰，點選 App Gallery，此時會 Show 出所有這個帳號下的AppSheet 

APP。
2. 點選欲放製作捷徑的 APP，此時會進入到該 APP，點選左上角☰，點選 Add 

Shortcut。

建立官方範本

製作捷徑

<<05:00>

Step by Step



[Data] 什麼是 Data ?

- 整個 APP 的資料來源，一個 APP 可以連結多個資料來源

- 定義 APP 所需要用到的資料

- 可於此處理資料顯示的邏輯

- 可於此做資料權限管理

- 可於此決定資料可操作的行為 (CRUD)



[Data] 資料管理介面

- 所有資料來源皆從

此介面進行設定。

- 定義資料欄位、型

態以及顯示設定 
( 必填? 是否顯示? )



小提示：Data

FORMULA v.s. INITIAL VALUE

FORMULA INITIAL VALUE

設計目的 內定值 初始值

可更改 不可 可



Step 1. 建立Google Sheet
1. 建一個Google Sheet，命名為「點餐系統」
2. 建立「產品」、「訂單」、「系統使用者」頁籤(Table)

Step 2. 建立頁籤(Table)欄位
● 產品：產品編號、產品類別、產品名稱、產品描述、單價、庫存數量
● 訂單：訂單編號、產品名稱、數量、單價、小計、訂購日期、訂單時間、客戶Email、目前庫存
● 客戶：客戶編號、客戶姓名、聯絡電話、電子郵件、地址、註冊日期

各建四筆假資料

Step 3. 建立 AppSheet 應用程式
1. 在Google Sheet中，擴充功能 -> AppSheet -> 建立應用程式，此時會帶入到AppSheet中

Step 4. 檢查修改type
1. 產品：產品編號(number)、產品類別(enum)、產品名稱(text)、產品描述(text)、單價

(price)、庫存數量(number)
2. 訂單：訂單編號(number)、產品名稱(enum)、數量(number)、單價(price)、小計(price)、訂

購日期(date)、訂單時間(time)、客戶Email(email)、目前庫存(number)
3. 客戶：客戶編號(number)、客戶姓名(text)、聯絡電話(number)、電子郵件(email)、地址

(text)、註冊日期(date)

在Google Sheet中
建立資料，並建立

AppSheet應用程式

<<2:00>>

Step by Step



Step 1. Data -> Columns -> 訂單
1. 在「訂購日期」往右看到FORMULA，輸入TODAY()

2. 在「訂單時間」往右看到INITIAL VALUE，輸入TIMENOW()

Step 2. 新增一筆訂單
1. 查看「訂購日期」、「訂單時間」有什麼不同

TODAY()
TIMENOW( )

<<1:00>>

Step by Step



Step 1. Data -> Columns -> 訂單
1. 在「訂單編號」往右看到INITIAL VALUE，輸入UNIQUEID()

2. 新增一筆訂單，觀察有沒有選擇「訂單編號」的畫面差異。

Step 1. Data -> Columns -> 訂單
1. 在「訂單編號」往右看到INITIAL VALUE，輸入max(訂單[訂單編號])+1

2. 新增一筆訂單，觀察有沒有選擇「訂單編號」的畫面差異。

UNIQUEID()
MAX( )

<<4:00>

Step by Step



Step 1. Data -> Columns -> 訂單
1. 「數量」欄位按下筆，在show?欄位上，輸入ISNOTBLANK([產品名稱])，按下done。

2. 新增一筆訂單，觀察有沒有選擇「產品名稱」的畫面差異。

show?
ISNOTBLANK( )

選擇了「產品名稱」，才會

跳出「數量」

<<2:00>>

Step by Step



Step 1. Data -> Columns -> 訂單
1. 「產品名稱」欄位按下筆，在valid if欄位上，輸入select(產品[產品名稱])，按下done。

2. 新增一個全新產品後，再新增一筆訂單，查看「產品名稱」是否在下拉選單出現

抓取產品名稱
欄位列表

select(你要抓資料的工作表名
稱[你要抓的工作表欄位],true)

<<04:00>

Step by Step



[Data] Virtual Column

1. 特殊的欄位

2. 此值須通過公式得出

3. 無需修改數據源

4. 動態顯示

使用場景：

若應用程式追踪設備的保養記錄，可以創建一個

Virtual Column，顯示距離下一次保養還有多少天，

基於最後一次保養日期和保養週期計算得出。

SELECT(產品[庫存數量], [_THISROW].[產品名稱]=[產品名稱])

要找的地方 目前所在的地方



Step 1. Data -> Columns -> 訂單
1. 按下Add Virtual Column，Name設為「庫存數量」，Type設為lis，FORMULA輸入

SELECT(產品[庫存數量], [_THISROW].[產品名稱]=[產品名稱])

2. 新增一筆訂單，選擇產品名稱後，看看有無出現「庫存數量」。

Virtual Column
即時取得庫存

<<5:00>

Step by Step

要找的地方 目前所在的地方



Step 1. Data -> Columns -> 訂單
1. 按下「數量」的筆，點選Data Validity，將以下條件輸入：

● Valid If：[數量] > 0
● Invalid value error：您輸入的數量不正確喔，請檢查！

2. 新增一筆訂單，選擇產品名稱後，將數量設為>=0，觀查看看。

Data Validity
數據有效性判斷

● Valid If：[數量] > 0
● Invalid value error：您輸入的

數量不正確喔，請檢查！

<<3:00>

Step by Step



[Data] 很重要的功能 - Slices

1. 資料安全性與隱私

2. 簡化資料

3. 避免資料重覆與資料破碎

● 應用場景：用戶分類和權限控制：  建立兩個不同的  Slices，分別用於一般使用者和管理者，限制他們能 夠查看和訪問的數據。

● 選單顯示： 建立兩個不同的  Slices，用於內部人員及外部客戶。外部客戶的 Slice 只顯示可訂購的項目，內部人員的  Slice 只顯

示所有項目，包括價格和庫存資訊。

● 訂單管理： 管理者可建立一個特定的  Slice，管理所有訂單的詳細資訊，例如訂單狀態、付款情況等。一般使用者的  Slice 只顯示

他們自己的訂單。

● 報告和分析： 使用 Slices，可建立不同的報告和分析圖表，顯示每日 /每月等不同報告。

● 活動推廣： 若需舉辦促銷活動，可以建立一個  Slice，只顯示參與活動的特定項目和價格。



Step 1. 在 Google Sheet中，增加「內部人員」頁籤，並設定以下欄位
● 員工編號(number)、姓名(text)、職位(enum)、部門(enum)、電子郵件(email)、權限(text)、地址

(text)、手機(number)、身分證字號 (text)。

「職位」為主管：「權限」設為 admin
「職位」為員工：「權限」設為 user

Step 2. 在 Appsheet中，Data->Tables加入此頁籤，並把TYPE設定好。

Step 3. 在 Appsheet中，Data->Slices->New Slice->create a new slice
將slice name改為「通訊錄(user用)」，Source Table改為「內部人員」，在Slice Columns中去除”權
限”、”地址”、”身分證字號”。

Step 4. 在 Appsheet中，Data->Slices->New Slice->create a new slice
將slice name改為「通訊錄(admin用)」，Source Table改為「內部人員」。

Step 5. 在 Appsheet中，UX->View->New View->create a new view。
● View name：通訊錄(user)。For this data：通訊錄(user用)。View type：table
● View name：通訊錄(admin)。For this data：通訊錄(admin用)。View type：table

Slices 切片

● Admin 權限可看到內部人員

私密資料 (如：地址、身分證

字號)

● User 權限只可看到內部人員

一般資料

<<5:00>

Step by Step



Step 1. 認識 Table
1. 測試 Updates、Adds、Deletes、Read-Only
2. New Table，把其它 Google Sheet 的頁籤 (Table) 都加入
3. AppSheet 中新增一筆資料，查看 Google Sheet 變化

Step 2. 認識 Columns
● TYPE：大頭照 (Image)、性別 (Enum, Buttons)
● 測試 KEY(不能重覆) / LABLE / SHOW / EDITABLE / REQUIRE / Search
● 測試 FORMULA / INITIAL VALUE / DISPLAY NAME
● 測試 UNIQUEID()、USEREMAIL()

各建一筆假資料

Step 3. 修改 Google Sheet 欄位
1. 在 Google Sheet 中，嘗試修改 Sheet 欄位，例如：「電子郵件」欄位改成「email」
2. 在 Appsheet -> Data -> Columns -> 點選上述修改的Column，按下Regenerate 

structure
3. 將 1 改回去，再執行一次 2

認識Data

<<5:00>>

Step by Step
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[UI/UX] 什麼是 UI/UX?

- 操控整個 APP 的畫面 (包含主畫面、編輯畫面、細節畫面)

- 可決定每個畫面想要呈現的樣式

- 可決定 APP 畫面的整體 Style

- 可客製特殊情況下的畫面顯示



[UI/UX] AppSheet Views Types



[UI/UX] Format Rules



Step 1. 
進入UX -> Views，選擇「通訊錄(admin)」

Step 2. 
進入Display -> Show if
輸入IN(LOOKUP(USEREMAIL(), 內部人員 , 電子郵件, 權限), LIST("admin"))，按下SAVE

Step 3. 
進入UX -> Views，選擇「通訊錄(user)」

Step 4. 
進入Display -> Show if
輸入IN(LOOKUP(USEREMAIL(), 內部人員 , 電子郵件, 權限), LIST("user"))，按下SAVE

Step 5. 
在右側下方的Preview app as，分別輸入客戶email、內部人員email (admin)、內部人員
email (user)，按下Apply，試看看會發生什麼事

View 顯示管理

<<05:00>

Step by Step

Table 欄位



Step 1. 
在Google Seet中，增加兩個頁籤「筆記」、「筆記內頁」。
筆記：編號、日期、電子郵件
筆記內頁：編號、筆記、圖片、地點GPS

Step 2. 
Data -> Columns -> 筆記內頁，
將「筆記內頁」TYPE 改為「Ref」，Source table 改為「筆記」，按下 SAVE

Step 3. 
試著新增筆記看看效果

Ref 關聯

<<05:00>

Step by Step
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[ACTION] 什麼是 Actions

- 在有限範圍內，提供使用者於畫面中有其他操作形式。

(ex. 一鍵設為管理員/設為成員等)

- 可一次群組化多項 Actions

- 通常搭配使用者畫面操作或是機器人執行

- 提供新增、刪除、修改、查詢外的選擇



[ACTION] -  行為種類

- 執行特定的操作。

- 協助 AppSheet 執行各種

不同的任務。也可以執行

一系列動作。

- 包含資料的改動、App畫
面的轉換等相關動作皆可

被設定執行。



[ACTION] - 執行預先定義好的行為

- 執行特定的操作。

- 協助 AppSheet 執行各種

不同的任務。也可以執行

一系列動作。

- 包含資料的改動、App畫
面的轉換等相關動作皆可

被設定執行。



Step 1. 
在 Appsheet中，Behavior->Action->New Action。
【註】記得Preview app as的email，是「內部人員」頁籤中，admin權
限的email

Step 2. 
Action name：設為 Admin
For a record of this table：內部人員
Do this：Data: set the values of some columns in this row
Set these columns：權限=”admin”

按下save

Step 3. 
通訊錄中，隨意點一個 User權限的人員，接著會進入到該人員資料
頁面。點選上方「設為 USER」按鈕，查看 Google Sheet「內部人員」
頁籤中，該人員的權限是否變為 Admin

一鍵設為
Admin 權限

<<05:00>

Step by Step



[ACTION] - 如何調用 Action

- 進入 UI/UX 畫面

- 點選 Use Action
- 選擇想要呈現的 Action



Data

UX

Behavior

Automation



[Automation] 什麼是 Automation?

- 希望自動化之事項

- 在有限的觸發條件及有限的處理行為下進行

- 可透過此機制寄信、寄推播、寄簡訊

- 可使用 Webhook

- 可設定排程執行



Step 1. 
進入UX -> Views，選擇需要的View。

Step 2. 
進入Display -> Show if

輸入IN(LOOKUP(USEREMAIL(), 系統使用者 , 電子郵件, 權限), LIST("admin"))，按下SAVE

View 顯示管理

<<05:00>

Step by Step
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收件人：

林育章

1111

2222

3333

收件人：

張四仁

4444

A4bcd

POPO



收件人：

吳明明

5678

U4371

B523

收件人：

陳萱萱

734

K4374

P523



Series B 
Funding
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AppSheet 應用整理



Solution: 原物料監控

   Data Pipeline
    DataŲow

Raw Data
Cloud Storage

BigQuery
Data Warehouse

Data
(Google Workspace)

  Looker
   Data Analytics &
   Visualization

Web/App
(Appsheet)

分析師供應商 母公司



案例２：BHI
Workspace 和 AppSheet 節省了 10% 的 IT 支出

Region: NORTHAM
Industry: Manufacturing & Industrials
Function: Inspections, Audits & QA
Customer Size: 100+
Name: BHI

問題１：現場人員

● 每天３０次檢查

● 紙本表單

● 輸入電腦

● 整理發送客戶

問題２：流程

● 緩慢且昂貴

● 抄寫易出錯

● 數據遺失失

問題３：IT

● 開發時間長

● 部署時間版本

● 控制困難

● 外包成本高

問題４：出貨

● 司機派遣

● 運輸派遣

● 現場交貨

● 出貨資源管理

產生效益

● 通過用AppSheet應用程序，BHI簡省10%的IT開發費用。

● 將原本需要2小時的檢查流程縮短到6分鐘，每月節省超過 50,000美元。

● BHI的車隊管理在程式發布後的一天 內開始收集170多輛車輛的各項數據，每周節省 30小時的時間。

● BHI已成為一家擁有實時數據的數位化公司，能 夠做出實時決策。

為什麼使用AppSheet

● 可與GWS整合

● 95%符合客戶使用情境

● 響應式、適用於移動設備且跨平台兼容

● 更快的開發週期

● 強大的協作社群



Region: NORTHAM
Industry: Manufacturing & Industrials
Function: Inspections, Audits & QA
Customer Size: 100+
Name: BHI

案例２：BHI
Workspace 和 AppSheet 節省了 10% 的 IT 支出



採購與供應

● 供應商清單

● RFP 管理

● 採購訂單管理

● 發票管理

● 採購流程

● 費用管理

製造

● 製造執行系統 (MES)
● 物料需求規劃 (MRP)
● 維護追蹤

● 資產管理

● 稽核和安全認證追蹤

倉儲與庫存

● 庫存追蹤

● 庫存管理

● 資產管理

● 倉儲管理系統 (WMS)

出貨

● 司機派遣

● 運輸派遣

● 現場交貨

● 出貨資源管理

AppSheet應用：供應鏈管理 



庫存追蹤

● 跟蹤庫存項目詳細信息

● 記錄進出庫存量

● 監控和分析庫存水平

[參考模板] AppSheet 應用：供應鏈管理 

任務管理

● 跟蹤一次性和重複性任務

● 創建具有截止時間的一次／重複性任務

● 優先順序分類與提醒

看板管理

● 跟蹤工單或項目在各個階段的狀態

● 在看板或日曆上查看活動及提醒

● 增加工作流和團隊成員



前端管理

● 運輸派遣

● 現場交貨

● 司機派遣

● 產品交貨

● 現場檢查

● 現場研究調查

● 貨運里程記錄

● 條碼掃描器

客戶互動

● 訪客登記

● 門店取貨

● 外送取貨

● 客戶互動追蹤

● 團隊警示

時間與費用

● 班表排程

● 班表管理

● 工時表/打卡

● 承包商工時表

● 承包商費用

● 費用管理

● 自動報告

● 薪資計算

● 報價產生器

● 產品/服務目錄

● 客戶簽名

AppSheet 應用：前端管理 



區域管理

● 追踨不同商品及各區域的數量

● 使員工密切關注產能

● 分析及監控數據

[參考模板] AppSheet 應用：前端管理 

班表管理

● 自動化批次安排班表／訊息通知員工

● 去除紙張管理及手動流程

● 員工溝通增加

取貨管理

● 管理客戶查詢、預約和取貨方式

● 客戶名冊管理

● 派發狀態表及日曆提醒



檢查

● 環境檢查

● 設備檢查

● 車輛檢查

● 清潔檢查

● 農業檢查

● 品質檢查

● 工作流程串連

● 送單批准

安全管理

● 工作場所安全

● 安全檢查表

● 安全審核

● 平面消毒

● 事故報告

● 健康紀錄

● 團隊警示

● 客戶警示

AppSheet應用：品控與安全管理

場地安全

● 場地安全管理

● 場地安全即時回報

● 場地安全處理狀況回應

[參考模板] 



招募

● 面試者管理

● 聘用信

● 合約管理

● 文件簽名

● 員工申請

● 申請者追蹤

● 申請者通知

時間及費用

● 班表排程管理

● 工時表/打卡

● 承包商工時表

● 承包商費用

● 費用管理

● 自動報告

● 薪資計算

培訓及績效

● 員工入職

● 線上員工培訓

● 績效管理

● 團隊資源

● 績效儀表板

員工管理

● 場地預訂/酒店管理

● 休假管理

● 團隊警示

● 員工福利

● 員工調查

● 通訊錄

● 員工申訴

AppSheet應用：人力資源及管理



員工管理

● 篩選新員工教育訓練資源

● 追蹤員工入職進度

● 查看教學活動並分析資源使用情況

[參考模板] AppSheet 應用：人力資源及管理 

設備空間管理

● 自動化批次安排班表／訊息通知員工

● 去除紙張管理及手動流程

● 員工溝通增加

團隊討論區

● 創建團隊留言板來解決組織溝通問題

● 團隊共享資源留存有價的隱性知識

● 直接或群發消息給同事

● 在線標記同事以回答問題或讓他們了解

現狀



專案和任務 資源和報告

● 資源中心

● 內容庫與管理

● 關鍵績效指標儀表板

● 工作流程自動化

● 自動通知

● 報告產出

專案追蹤

● 任務管理

● 看板監視

● 開單建立

● 待辦事項清單

● 簡易排程器

● 審核批准

● 每日報告

● 財務預算管理

● 採購訂單管理

● 預算規劃及追蹤

● 工作估算計算器

● 現場數據收集

● RFP 管理

● 費用追蹤

AppSheet 應用：專案與活動管理

專案追蹤

● 跟蹤工單或項目在各個階段的狀態

● 在看板或日曆上查看活動及提醒

● 增加工作流和團隊成員

[參考模板] 



銷售支援 行銷

● 行銷專案管理員

● 行銷日曆

● 資料內容庫

● 新聞稿監控

● 客戶調查

● 承包商管理

● 客戶關係管理 (CRM)
● 潛在客戶分析及追蹤

● 活動追蹤

● 報價單產生器

● 產品目錄

● 商機追蹤

● 區域地圖

● 合約生成及批准

● 競爭情報

● 客戶簽名

● 銷售分析

● 銷售績效

客戶服務

● 客戶資料庫

● 客戶意見

● 客戶諮詢

● 服務分析

● 報修單

● 客戶提醒

● 自動化郵件

AppSheet 應用：行銷與銷售管理



CRM

● 聯繫人、公司、機會、報價和產品

● 商機增加／修改／管理

● 商機階段設置與追蹤

[參考模板] AppSheet 應用：行銷與銷售管理

營銷專案管理

● 監控營銷活動階段及預算

● 團隊和進度組織營銷項目管理

● 可自定義分組分配任務、跟蹤進度和專案

進行排序整理

客服管理

● 監控和分析員工處理指標

● 自定增加和其他內容連結

● 為用戶和團隊進行分類內容



Series B 
Funding

05
結語



操作

建立資料模型

七大步驟

介面邏輯

簡單App製作

理解

需求探索

實務應用場景

AppSheet用途 / 特色

設計構思

8/11 AppSheet無程式碼開發教學 (上)



AppSheet特色

快速應用開發

1天 至 1週

提升行動力

現場、前線、外勤

整合多個數據源

Dropbox、SQL、Sheet…

可在不同裝置使用，無論是在

會議中、活動現場還是外勤工

作中，皆可方便地使用

AppSheet 應用程式執行任務，

並即時收集和更新數據。

可連接和整合多個數據來源，

例如資料庫、試算表、線上服務

等。

輕鬆地將不同來源的數據整合

到應用程式中，實現全面的數

據管理和分析，並更好地管理

公司及客戶。

低代碼開發平台，非技術人員

也能快速創建專屬的應用程式

，無需編寫繁瑣的程式碼。

滿足不同行銷需求，包括活動

報名、產品展示、客戶調查等，

加快行銷活動的執行速度。



需求探討

How
方案

Why
問題

When
場景

Who
人

When
發生時間

What
執行

Deep Why
底層問題



文檔資料 解決問題場景使用者

● 辦公室
● 門店
● 現場
● 工廠
● 倉庫
● 業務財務
● 物流配送
● 客戶互動
● 前台 / 後台
● 上游 / 中游 / 下游

● 新進人員
● 內勤人員
● 外勤人員
● 專業人員
● 對外服務
● 管理者
● 查驗人員
● 配送人員
● 供應商 / 承包商

● 定期檢查
● 問卷回饋
● 規劃討論
● 項目追蹤
● 掃描辨識
● 分類記錄
● 服務
● 簽署
● 申請批淮
● 活動管理
● 時間地點記錄

● 品質穩定
● 資源分配
● 快速調度
● 時間效率
● 準確率提高
● 信賴關係
● 有效管理
● 提醒通知
● 創新創造

需求探討



現場使用 連結互動辦公室品控維護

● 申請單與批淮

● 專案管理和協作

● 預算規劃和追蹤

● CRM 附加功能

● 打卡請假

● 安全檢查/品質保證

● 設施和維護

● 設備檢查

● 時間排程

● 庫存追蹤

● 司機調度

● 物流派送

● 確認簽名

● 現場服務

● 現場資源管理

● 資產管理

● 廠商管理

● 條碼掃描

● 提案和報價產出

● 專案排程管理

● 客戶管理

● 通知提醒

● 教育訓練

● FAQ

場景需求




